Domestic Business Identity Creation

Incident Report for Fortress Trust

Resolved

This incident has been resolved.
Posted May 28, 2025 - 18:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 19, 2024 - 17:18 UTC

Identified

We are aware of an issue where TIN/EIN checks are blocking the creation of Domestic Business Identities . All Domestic Business Identities created will now be auto suspended until our compliance team reviews. A resolution is currently being worked on. For questions or concerns please submit a ticket at support.fortresstrust.com
Posted Nov 14, 2024 - 18:28 UTC
This incident affected: Trust API (Identities - Business).