Delayed BTC Withdrawals

Incident Report for Fortress Trust

Resolved

This incident has been resolved.
Posted Aug 20, 2025 - 13:59 UTC

Investigating

We are currently investigating the issue.
Posted Aug 20, 2025 - 01:44 UTC
This incident affected: Trust API (Transactions - Crypto).