Crypto Withdrawal Degradation

Incident Report for Fortress Trust

Resolved

This incident has been resolved.
Posted May 08, 2025 - 23:34 UTC

Update

We are continuing to investigate this issue.
Posted May 08, 2025 - 20:48 UTC

Investigating

We are currently investigating an issue causing crypto withdrawal failures.
Posted May 08, 2025 - 19:34 UTC
This incident affected: Trust API (Transactions - Crypto).