Delayed Crypto Deposits & Withdrawals - Gas/Transaction Fee Volatility

Incident Report for Fortress Trust

Resolved

This incident has been resolved.
Posted Jul 30, 2025 - 14:55 UTC

Investigating

We are currently investigating the issue.
Posted Jul 30, 2025 - 14:17 UTC
This incident affected: Trust API (Transactions - Crypto).