Sandbox Degradation

Incident Report for Fortress Trust

Resolved

This incident has been resolved.
Posted Jul 10, 2025 - 04:10 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 09, 2025 - 15:16 UTC

Identified

Sandbox Environment is experiencing errors due to the custody provider configuration. We are currently implementing a resolution.
Posted Jul 07, 2025 - 14:18 UTC
This incident affected: Trust API (Accounts - Custodial Account Creation, Transactions - Fiat) and Integrator Dashboard.