Delayed Crypto Deposits & Withdrawals - Gas/Transaction Fee Volatility

Incident Report for Fortress Trust

Resolved

This incident has been resolved.
Posted Jul 17, 2025 - 17:26 UTC

Investigating

We are currently investigating the situation.
Posted Jul 17, 2025 - 16:55 UTC
This incident affected: Trust API (Transactions - Crypto).